CVE-2026-123616: imgproxy from 3.3.0 before 4.0.16 contains an unbounded memory allocation vulnerability in the ICO
Source GCVE Database
Not known to be exploited · CVSS 8.7 High : upgrade to 4.0.16 soon.
Data as of 8 Nov 2026, 06:20 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.7 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.5 |
- Patch
- Available – fixed in 4.0.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade imgproxy and imgproxy/imgproxy to 4.0.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| imgproxyimgproxy | Affected
| Fixed in
|
GitHubimgproxy/imgproxypkg:github/imgproxy/imgproxyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version is available starting from imgproxy 4.0.16. Users should upgrade to version 4.0.16 or later to remediate this vulnerability. No other mitigations or workarounds are indicated.
Description
A vulnerability in imgproxy versions from 3.3.0 up to but not including 4.0.16 allows attackers to cause unbounded memory allocation via a crafted ICO file. The flaw arises because the ICO loader does not validate the data_size field, enabling memory exhaustion and worker crashes without requiring authentication.