Skip to main content
VulnerabilityPublished Updated

CVE-2026-103658: aspell security update

Affects aspellSource GCVE Database

0
Compare
Authoritative record:CVE-2026-103658· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 12:0.60.8-9.el9_8 when convenient.

Data as of 30 Oct 2026, 16:17 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 12:0.60.8-9.el9_8
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the AlmaLinux to 12:0.60.8-9.el9_8.

Affected software

ProductAffectedFixed in
AlmaLinux 9aspellAffected
  • <12:0.60.8-9.el9_8
Fixed in
  • 12:0.60.8-9.el9_8
AlmaLinux 9aspell-develAffected
  • <12:0.60.8-9.el9_8
Fixed in
  • 12:0.60.8-9.el9_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in Aspell version 0.60.8-9.el9_8 and later. Users should apply the update provided by their vendor, such as the Red Hat advisory RHSA-2026:92458, to remediate this issue. No additional mitigation steps are indicated by the vendor.

Description

GNU Aspell, a spell checker used as a library or standalone tool, contains a vulnerability (CVE-2026-103658) that allows arbitrary code execution via a crafted dictionary file. This security flaw affects versions prior to 0.60.8-9.el9_8 in Red Hat Enterprise Linux 9.8 Extended Update Support. A security update addressing this issue is available and should be applied to affected systems.

References

Community reviews

Loading reviews…