Skip to main content
VulnerabilityPublished Updated

CVE-2026-111497: brotli security update

Affects brotliSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.0.9-10.el9_8.1 as a priority.

Data as of 27 Oct 2026, 02:29 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.9-10.el9_8.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.0.9-10.el9_8.1.

Affected software

ProductAffectedFixed in
AlmaLinux 9brotliAffected
  • <1.0.9-10.el9_8.1
Fixed in
  • 1.0.9-10.el9_8.1
AlmaLinux 9brotli-develAffected
  • <1.0.9-10.el9_8.1
Fixed in
  • 1.0.9-10.el9_8.1
AlmaLinux 9libbrotliAffected
  • <1.0.9-10.el9_8.1
Fixed in
  • 1.0.9-10.el9_8.1
AlmaLinux 9python3-brotliAffected
  • <1.0.9-10.el9_8.1
Fixed in
  • 1.0.9-10.el9_8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in brotli version 1.0.9-10.el9_8.1 for Red Hat Enterprise Linux 9. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory RHSA-2026:90495 for detailed update instructions.

Description

An out-of-bounds write vulnerability (CVE-2026-111497) was discovered in the Google Brotli decoder, a lossless compression algorithm used in various Red Hat Enterprise Linux 9 distributions. This vulnerability could potentially lead to memory corruption. Red Hat has released a security update fixing this issue in brotli version 1.0.9-10.el9_8.1.

References

Community reviews

Loading reviews…