Skip to main content
VulnerabilityPublished Updated

CVE-2026-111497: brotli security update

Affects brotliSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical : upgrade to 1.1.0-8.el10_2.1 as a priority.

Data as of 27 Oct 2026, 09:14 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.0-8.el10_2.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.1.0-8.el10_2.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10brotliAffected
  • <1.1.0-8.el10_2.1
Fixed in
  • 1.1.0-8.el10_2.1
AlmaLinux 10brotli-develAffected
  • <1.1.0-8.el10_2.1
Fixed in
  • 1.1.0-8.el10_2.1
AlmaLinux 10libbrotliAffected
  • <1.1.0-8.el10_2.1
Fixed in
  • 1.1.0-8.el10_2.1
AlmaLinux 10python3-brotliAffected
  • <1.1.0-8.el10_2.1
Fixed in
  • 1.1.0-8.el10_2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of Brotli (1.1.0-8.el10_2.1) is available and should be applied to affected Red Hat Enterprise Linux 10 systems. Users should follow the Red Hat advisory instructions to update their packages promptly. No additional mitigation steps are indicated by the vendor.

Description

An out-of-bounds write vulnerability (CVE-2026-111497) has been identified in the Google Brotli decoder, a lossless compression algorithm used in Red Hat Enterprise Linux 10. This flaw could potentially lead to memory corruption. Red Hat has released an important security update to address this issue in version 1.1.0-8.el10_2.1.

References

Community reviews

Loading reviews…