Skip to main content
VulnerabilityPublished Updated

CVE-2026-100236: dpdk security update

Affects dpdkSource GCVE Database

0
Compare
Authoritative record:CVE-2026-100236· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 2:25.11-2.el9_8 soon.

Data as of 5 Nov 2026, 04:28 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.6
Patch
Available – fixed in 2:25.11-2.el9_8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the AlmaLinux to 2:25.11-2.el9_8.

Affected software

ProductAffectedFixed in
AlmaLinux 9dpdkAffected
  • <2:25.11-2.el9_8
Fixed in
  • 2:25.11-2.el9_8
AlmaLinux 9dpdk-develAffected
  • <2:25.11-2.el9_8
Fixed in
  • 2:25.11-2.el9_8
AlmaLinux 9dpdk-docAffected
  • <2:25.11-2.el9_8
Fixed in
  • 2:25.11-2.el9_8
AlmaLinux 9dpdk-toolsAffected
  • <2:25.11-2.el9_8
Fixed in
  • 2:25.11-2.el9_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in dpdk version 2:25.11-2.el9_8. Users should apply this update promptly to remediate the issues. Refer to the Red Hat advisory RHSA-2026:94629 for detailed update instructions. No additional mitigation actions are indicated by the vendor advisory.

Description

Multiple security vulnerabilities have been identified in the Data Plane Development Kit (dpdk) affecting versions prior to 2:25.11-2.el9_8. These include various memory corruption issues such as out-of-bounds reads and writes, buffer overflows, use-after-free, type confusion, and time-of-check/time-of-use (TOCTOU) race conditions primarily in vhost and vhost-crypto components. These flaws could potentially be triggered by a guest in a virtualized environment, leading to memory corruption on the host. A security update fixing these issues is available.

References

Community reviews

Loading reviews…