CVE-2026-5201: gdk-pixbuf2 security update
Affects gdk-pixbuf2Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 2.42.6-6.el9_7.1 soon.
Data as of 27 Oct 2026, 00:16 UTC
- Patch
- Available – fixed in 2.42.6-6.el9_7.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux to 2.42.6-6.el9_7.1.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9gdk-pixbuf2 | Affected
| Fixed in
|
| AlmaLinux 9gdk-pixbuf2-devel | Affected
| Fixed in
|
| AlmaLinux 9gdk-pixbuf2-modules | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official security update provided by Red Hat to upgrade gdk-pixbuf2 to version 2.42.6-6.el9_7.1 or later. This update fixes the heap-based buffer overflow vulnerability. No additional mitigation steps are required beyond applying this patch.
Description
A heap-based buffer overflow vulnerability exists in gdk-pixbuf2 when processing specially crafted JPEG images, leading to a denial of service condition. This affects versions prior to 2.42.6-6.el9_7.1. The issue has been rated as Important by Red Hat and fixed in version 2.42.6-6.el9_7.1.