Skip to main content
VulnerabilityPublished

CVE-2026-112177: ghostscript security update

Affects ghostscriptSource GCVE Database

0
Compare
Authoritative record:CVE-2026-112177· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 9.27-20.el8_10 soon.

Data as of 3 Nov 2026, 00:00 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.3
Patch
Available – fixed in 9.27-20.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade the AlmaLinux to 9.27-20.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8ghostscriptAffected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10
AlmaLinux 8ghostscript-docAffected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10
AlmaLinux 8ghostscript-tools-dvipdfAffected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10
AlmaLinux 8ghostscript-tools-fontsAffected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10
AlmaLinux 8ghostscript-tools-printingAffected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10
AlmaLinux 8ghostscript-x11Affected
  • <9.27-20.el8_10
Fixed in
  • 9.27-20.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update provided by Red Hat for Ghostscript to version 9.27-20.el8_10 or later. This update fixes the .charkeys -dSAFER bypass vulnerability. Refer to Red Hat's advisory and update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps.

Description

A security vulnerability (CVE-2026-112177) in the Ghostscript suite affects versions prior to 9.27-20.el8_10 on Red Hat Enterprise Linux 8. The issue involves a reintroduction of a .charkeys -dSAFER bypass, which could allow unsafe PostScript code execution. A security update is available that fixes this vulnerability.

References

Community reviews

Loading reviews…