Skip to main content
VulnerabilityPublished Updated

CVE-2026-4878: libcap security update

Affects libcapSource GCVE Database

0
Authoritative record:CVE-2026-4878· Medium 6.7

Not known to be exploited · CVSS 6.7 Medium : upgrade to 2.69-7.el10_1.1 when convenient.

Data as of 27 Oct 2026, 00:38 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.69-7.el10_1.1
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 2.69-7.el10_1.1.

Affected software

ProductAffectedFixed in
AlmaLinux 10libcapAffected
  • <2.69-7.el10_1.1
Fixed in
  • 2.69-7.el10_1.1
AlmaLinux 10libcap-develAffected
  • <2.69-7.el10_1.1
Fixed in
  • 2.69-7.el10_1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available and should be applied. Red Hat has released fixed packages at version 2.69-7.el10_1.1 for Red Hat Enterprise Linux 10 and its variants. Users should update to this version or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

A privilege escalation vulnerability exists in libcap due to a time-of-check to time-of-use (TOCTOU) race condition in the cap_set_file() function. This flaw allows an attacker to potentially escalate privileges by exploiting the race condition. The issue affects versions of libcap prior to 2.69-7.el10_1.1. A security update fixing this vulnerability is available from Red Hat for Red Hat Enterprise Linux 10 and related variants.

References

Community reviews

Loading reviews…