Skip to main content
VulnerabilityPublished

CVE-2026-94453: libreswan security update

Affects libreswanSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-94453· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.3.3-1.el10_2 soon.

Data as of 26 Oct 2026, 23:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.3.3-1.el10_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 5.3.3-1.el10_2.

Affected software

ProductAffectedFixed in
AlmaLinux 10libreswanAffected
  • <5.3.3-1.el10_2
Fixed in
  • 5.3.3-1.el10_2
AlmaLinux 10libreswan-minimalAffected
  • <5.3.3-1.el10_2
Fixed in
  • 5.3.3-1.el10_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in libreswan version 5.3.3-1.el10_2 that addresses these vulnerabilities. Users should apply this update promptly to remediate the issues. Refer to the vendor advisory and update instructions at https://access.redhat.com/articles/11258 for detailed guidance. No additional mitigation steps are indicated by the vendor.

Description

Libreswan, an IPsec and IKE implementation for Linux, has multiple security vulnerabilities including a use-after-free bug in IKEv2 when using IKE-over-TCP (CVE-2026-94453), a denial of service via bogus X.509 certificates (CVE-2026-77205), and a null pointer dereference in PKCS#7 bundles with no certificates (CVE-2026-77207). These issues affect versions prior to 5.3.3-1.el10_2. A security update fixing these vulnerabilities is available.

References

Community reviews

Loading reviews…