Skip to main content
VulnerabilityPublished

CVE-2026-101911: nodejs:24 security, bug fix, and enhancement update

Affects nodejsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-101911· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 1:24.22.1-3.module_el9.8.0+333+788f3075 : update nodejs when convenient.

Data as of 30 Oct 2026, 02:00 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:24.22.1-3.module_el9.8.0+333+788f3075, 3.1.14-3.module_el9.8.0+292+f4eaf8b2, 2021.06-6.module_el9.7.0+209+ecf6523e +2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
AlmaLinux 9nodejsAffected
  • <1:24.22.1-3.module_el9.8.0+333+788f3075
Fixed in
  • 1:24.22.1-3.module_el9.8.0+333+788f3075
AlmaLinux 9nodejs-develAffected
  • <1:24.22.1-3.module_el9.8.0+333+788f3075
Fixed in
  • 1:24.22.1-3.module_el9.8.0+333+788f3075
AlmaLinux 9nodejs-docsAffected
  • <1:24.22.1-3.module_el9.8.0+333+788f3075
Fixed in
  • 1:24.22.1-3.module_el9.8.0+333+788f3075
AlmaLinux 9nodejs-full-i18nAffected
  • <1:24.22.1-3.module_el9.8.0+333+788f3075
Fixed in
  • 1:24.22.1-3.module_el9.8.0+333+788f3075
AlmaLinux 9nodejs-libsAffected
  • <1:24.22.1-3.module_el9.8.0+333+788f3075
Fixed in
  • 1:24.22.1-3.module_el9.8.0+333+788f3075
AlmaLinux 9nodejs-nodemonAffected
  • <3.1.14-3.module_el9.8.0+292+f4eaf8b2
Fixed in
  • 3.1.14-3.module_el9.8.0+292+f4eaf8b2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for the Node.js 24 module is available and should be applied. The fixed versions are 1:24.22.1-3.module_el9.8.0+333+788f3075 and later as listed. Users should update to these versions to remediate the vulnerabilities. Refer to the Red Hat advisory RHSA-2026:92378 for detailed update instructions. No additional mitigations are indicated beyond applying the official patch.

Description

Multiple security vulnerabilities affecting Node.js 24 have been addressed in this update, including denial of service via unbounded IPv6 address parsing, TLS certificate hostname bypasses, authentication bypasses, and other flaws. The update rebases Node.js 24 to the latest release with important security fixes and bug enhancements. Users of affected versions should apply the update to mitigate these issues.

References

Community reviews

Loading reviews…