Skip to main content
VulnerabilityPublished

CVE-2026-34588: openexr security update

Affects openexrSource GCVE Database

0
Authoritative record:CVE-2026-34588· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 3.1.10-8.el10_1.2 soon.

Data as of 27 Oct 2026, 00:28 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.1.10-8.el10_1.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 3.1.10-8.el10_1.2.

Affected software

ProductAffectedFixed in
AlmaLinux 10openexrAffected
  • <3.1.10-8.el10_1.2
Fixed in
  • 3.1.10-8.el10_1.2
AlmaLinux 10openexr-develAffected
  • <3.1.10-8.el10_1.2
Fixed in
  • 3.1.10-8.el10_1.2
AlmaLinux 10openexr-libsAffected
  • <3.1.10-8.el10_1.2
Fixed in
  • 3.1.10-8.el10_1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied immediately. The fixed version is 3.1.10-8.el10_1.2. Users should update OpenEXR packages to this version or later as provided by their vendor. No additional mitigation steps are specified by the vendor advisory.

Description

A security vulnerability (CVE-2026-34588) in OpenEXR allows arbitrary code execution and information disclosure via a crafted EXR file. OpenEXR is an open-source high-dynamic-range floating-point image file format used for high-quality image processing and storage. This vulnerability affects versions of OpenEXR prior to 3.1.10-8.el10_1.2. A security update has been released by Red Hat to address this issue.

References

Community reviews

Loading reviews…