CVE-2026-6100: Important · python3.12 security update
Affects python-unversioned-commandSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.12.12-3.el10_1.3 as a priority.
Data as of 27 Oct 2026, 00:16 UTC
- Patch
- Available – fixed in 3.12.12-3.el10_1.3
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux python-unversioned-command package to 3.12.12-3.el10_1.3.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 10python-unversioned-command | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and has been released in Python version 3.12.12-3.el10_1.3 and corresponding Red Hat Enterprise Linux 10 updates. Users should apply the official update from Red Hat as described in advisory RHSA-2026:10711 to remediate these vulnerabilities. No additional mitigation steps are indicated beyond applying the update.
Description
A security update for Python 3.12 addresses a use-after-free vulnerability in decompression modules (CVE-2026-6100) that could lead to arbitrary code execution or information disclosure. This update also fixes a separate arbitrary code execution vulnerability via command injection in the webbrowser.open() API (CVE-2026-4786). The vulnerabilities affect Python versions prior to 3.12.12-3.el10_1.3. Red Hat has released an important security advisory with patches for affected Red Hat Enterprise Linux 10 variants.
References
- access.redhat.com/errata/RHSA-2026:10711 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-4786 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-6100 (opens in a new tab)
- bugzilla.redhat.com/2457932 (opens in a new tab)
- bugzilla.redhat.com/2458049 (opens in a new tab)
- errata.almalinux.org/10/ALSA-2026-10711.html (opens in a new tab)