CVE-2026-35535: sudo security update
Affects sudoSource GCVE Database
Not known to be exploited · CVSS 7.4 High : upgrade to 1.9.5p2-15.el9_7 soon.
Data as of 27 Oct 2026, 00:37 UTC
- Patch
- Available – fixed in 1.9.5p2-15.el9_7
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the AlmaLinux to 1.9.5p2-15.el9_7.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 9sudo | Affected
| Fixed in
|
| AlmaLinux 9sudo-python-plugin | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official security update provided by Red Hat, which fixes the vulnerability in sudo version 1.9.5p2-15.el9_7. Systems running affected versions should be updated promptly following Red Hat's guidance. No additional mitigation actions are indicated beyond applying the patch.
Description
A privilege escalation vulnerability exists in the sudo utility due to failure in privilege drop calls. This flaw allows certain users to gain elevated privileges improperly. The issue affects sudo versions prior to 1.9.5p2-15.el9_7. A security update addressing this vulnerability is available and has been released by Red Hat for multiple Red Hat Enterprise Linux 9 variants.