Skip to main content
VulnerabilityPublished Updated

CVE-2026-88047: tesseract security update

Affects tesseractSource GCVE Database

0
Compare
Authoritative record:CVE-2026-88047· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 4.1.1-7.el8_10 soon.

Data as of 6 Nov 2026, 13:06 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.1.1-7.el8_10
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade the AlmaLinux to 4.1.1-7.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8tesseractAffected
  • <4.1.1-7.el8_10
Fixed in
  • 4.1.1-7.el8_10
AlmaLinux 8tesseract-develAffected
  • <4.1.1-7.el8_10
Fixed in
  • 4.1.1-7.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in Tesseract version 4.1.1-7.el8_10. Users should apply this update promptly to remediate the issue. Refer to the Red Hat advisory RHSA-2026:95725 for detailed update instructions. No additional mitigation steps are indicated by the vendor.

Description

Tesseract OCR engine versions prior to 4.1.1-7.el8_10 contain a stack buffer overflow vulnerability triggered by a crafted .traineddata file (CVE-2026-88047). This flaw can lead to memory corruption and potentially allow arbitrary code execution or denial of service. The vulnerability is part of a set of heap and stack out-of-bounds write/read issues addressed in a security update. Red Hat has released a patch fixing this issue in version 4.1.1-7.el8_10.

References

Community reviews

Loading reviews…