Skip to main content
VulnerabilityPublished Updated

CVE-2026-65182: tomcat security update

Affects tomcatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-65182· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1:9.0.121-1.el8_10 as a priority.

Data as of 31 Oct 2026, 09:39 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:9.0.121-1.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the AlmaLinux to 1:9.0.121-1.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8tomcatAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10
AlmaLinux 8tomcat-admin-webappsAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10
AlmaLinux 8tomcat-docs-webappAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10
AlmaLinux 8tomcat-el-3.0-apiAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10
AlmaLinux 8tomcat-jsp-2.3-apiAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10
AlmaLinux 8tomcat-libAffected
  • <1:9.0.121-1.el8_10
Fixed in
  • 1:9.0.121-1.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied immediately. Red Hat has released fixed packages for Red Hat Enterprise Linux 8, specifically version 1:9.0.121-1.el8_10 and later. Users should update affected Tomcat installations to this version or later to remediate these vulnerabilities. Refer to the Red Hat advisory RHSA-2026:92869 and the update instructions at https://access.redhat.com/articles/11258 for detailed guidance.

Description

Multiple security vulnerabilities have been identified in Apache Tomcat, including a security constraint bypass due to improper access control (CVE-2026-65182) among others. These issues affect versions prior to 1:9.0.121-1.el8_10 and have been addressed in the fixed version 1:9.0.121-1.el8_10. The vulnerabilities include access control bypasses, improper input validation, and authentication bypasses. Red Hat has issued an important security update for affected Red Hat Enterprise Linux 8 distributions to remediate these issues.

References

Community reviews

Loading reviews…