Skip to main content
VulnerabilityPublished Updated

CVE-2025-67733: valkey security update

Affects valkeySource GCVE Database

0
Compare
Authoritative record:CVE-2025-67733· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 8.0.7-1.el9_7 soon.

Data as of 29 Oct 2026, 14:41 UTC

CVSS 3.1 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.7-1.el9_7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the AlmaLinux to 8.0.7-1.el9_7.

Affected software

ProductAffectedFixed in
AlmaLinux 9valkeyAffected
  • <8.0.7-1.el9_7
Fixed in
  • 8.0.7-1.el9_7
AlmaLinux 9valkey-develAffected
  • <8.0.7-1.el9_7
Fixed in
  • 8.0.7-1.el9_7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official security update to Valkey version 8.0.7-1.el9_7 or later to remediate this vulnerability. The vendor advisory from Red Hat provides detailed instructions for updating affected systems. No additional mitigation steps are required beyond applying the patch.

Description

Valkey, an advanced key-value store supporting various data types and Lua scripting, contains a vulnerability (CVE-2025-67733) involving improper handling of null characters in Lua scripts. This flaw allows data tampering and denial of service. A security update fixing this issue is available in version 8.0.7-1.el9_7. The vulnerability affects versions prior to this fixed release. The vendor has rated the security impact as Important and has provided an official patch.

References

Community reviews

Loading reviews…