Skip to main content
VulnerabilityPublished Updated

CVE-2026-33999: Important · xorg-x11-server security update

Affects xorg-x11-server-XdmxSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-33999· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 1.20.11-28.el8_10 soon.

Data as of 27 Oct 2026, 00:16 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.20.11-28.el8_10
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the AlmaLinux to 1.20.11-28.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8xorg-x11-server-XdmxAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10
AlmaLinux 8xorg-x11-server-XephyrAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10
AlmaLinux 8xorg-x11-server-XnestAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10
AlmaLinux 8xorg-x11-server-XorgAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10
AlmaLinux 8xorg-x11-server-XvfbAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10
AlmaLinux 8xorg-x11-server-commonAffected
  • <1.20.11-28.el8_10
Fixed in
  • 1.20.11-28.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and should be applied to affected systems. The fixed version is 1.20.11-28.el8_10. Administrators should update xorg-x11-server to this version or later to remediate these vulnerabilities. Refer to the Red Hat advisory RHSA-2026:11692 for detailed update instructions. No additional mitigation steps are indicated by the vendor.

Description

Multiple security vulnerabilities have been identified in the X.Org X server component of xorg-x11-server, specifically in the xwayland module. These include a denial of service caused by an integer underflow in XKB compatibility map handling (CVE-2026-33999), a use-after-free vulnerability that can lead to server crashes and potential memory corruption (CVE-2026-34001), and information exposure and denial of service via out-of-bounds memory access (CVE-2026-34003). A security update addressing these issues is available in version 1.20.11-28.el8_10.

References

Community reviews

Loading reviews…