CVE-2024-5470: GitLab · Improper Access Control
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.1.2 or 17.0.4 when convenient.
Data as of 26 Oct 2026, 09:15 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.1.2, 17.0.4
Exploitation evidence
Disclosed: evidence found.
CVE published 13 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.1.2 or 17.0.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade to GitLab CE/EE version 17.0.4 or later and 17.1.2 or later to remediate this vulnerability.
Description
GitLab CE/EE versions from 17.0.0 up to but not including 17.0.4 and from 17.1.0 up to but not including 17.1.2 contain an improper access control vulnerability. This flaw allows a Guest user with the 'admin_push_rules' permission to create project-level deploy tokens, which is beyond the intended permission scope. The issue has been addressed in versions 17.0.4 and 17.1.2. The severity of this vulnerability is considered low.