Skip to main content
CVE-2024-5655VulnerabilityPublished Updated

CVE-2024-5655: GitLab · Improper Access Control

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.1.1 : patch gitlab as a priority.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
7.4% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1.1, 17.0.3, 16.11.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade gitlab to 17.1.1, 17.0.3 or 16.11.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=15.8.0 <16.11.5
  • >=17.0.0 <17.0.3
  • >=17.1.0 <17.1.1
Fixed in
  • 16.11.5
  • 17.0.3
  • 17.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab CE/EE versions to 16.11.5 or later, 17.0.3 or later, and 17.1.1 or later to remediate the issue. Applying these official fixes will prevent exploitation of this improper access control vulnerability.

Description

GitLab CE/EE versions from 15.8 up to but not including 16.11.5, 17.0 up to 17.0.3, and 17.1 up to 17.1.1 contain an improper access control vulnerability. This flaw allows an attacker to trigger a pipeline as another user under certain conditions. A patch is available to address this issue.

References

Community reviews

Loading reviews…