Skip to main content
CVE-2024-6385VulnerabilityPublished Updated

CVE-2024-6385: GitLab · Improper Access Control

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.1.2 : patch gitlab as a priority.

Data as of 25 Oct 2026, 19:02 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
7.1% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1.2, 17.0.4, 16.11.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade gitlab to 17.1.2, 17.0.4 or 16.11.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=15.8.0 <16.11.6
  • >=17.0.0 <17.0.4
  • >=17.1.0 <17.1.2
Fixed in
  • 16.11.6
  • 17.0.4
  • 17.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab CE/EE to versions 16.11.6, 17.0.4, or 17.1.2 or later, where this vulnerability has been fixed. Applying these official patches is the recommended remediation. No alternative mitigations or temporary fixes are indicated.

Description

GitLab CE/EE versions from 15.8 up to but not including 16.11.6, from 17.0 up to but not including 17.0.4, and from 17.1 up to but not including 17.1.2 contain an improper access control vulnerability. This flaw allows an attacker to trigger a pipeline as another user under certain conditions. The issue has been fixed in versions 16.11.6, 17.0.4, and 17.1.2. No known exploits are reported in the wild at this time.

References

Community reviews

Loading reviews…