CVE-2025-12893: Improper Certificate Validation May Allow Successful TLS Handshaking Despite Invalid Extended Key Usage Fields in MongoDB Server
Affects mongodbSource GCVE Database
Not known to be exploited · CVSS 4.2 Medium · fixed in 8.2.2 : update mongodb when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.09% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.2.2, 8.0.16, 7.0.26
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade mongodb to 8.2.2, 8.0.16 or 7.0.26.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimongodbpkg:bitnami/mongodbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official patches by upgrading MongoDB Server to versions 7.0.26, 8.0.16, or 8.2.2 or later. These versions contain fixes that enforce proper Extended Key Usage validation during TLS handshakes. No other mitigation is indicated by the vendor advisory.
Description
MongoDB Server versions prior to 7.0.26, 8.0.16, and 8.2.2 on Windows and Apple platforms improperly validate Extended Key Usage (EKU) fields during TLS handshakes. This allows clients or servers with certificates missing the required EKU attributes (clientAuth or serverAuth) to successfully complete TLS handshakes. Linux systems are not affected by this issue. The vulnerability has been fixed in the specified later versions.