Skip to main content
CVE-2026-105236VulnerabilityPublished Updated

Erlang/OTP · Improper Certificate Validation Vulnerability

Affects erlangSource GCVE Database

0
Authoritative record:CVE-2026-105236· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 27.3.4.19 : update erlang when convenient.

Data as of 29 Oct 2026, 00:45 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 27.3.4.19
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10erlangpkg:deb/ubuntu/erlang?arch=source&distro=stonkingOther threatsAffected
  • =1:27.3.4.6+dfsg-1
  • =1:27.3.4.12+dfsg-1
  • =1:29.0.6+dfsg-1
Fixed in–
Ubuntu 26.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=resoluteOther threatsAffected
  • 1:27.3.4.1+dfsg-1build1 – 1:27.3.4.6+dfsg-1ubuntu0.2
6 affected builds
Fixed in–
Ubuntu 24.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=nobleOther threatsAffected
  • 1:25.2.3+dfsg-1 – 1:25.3.2.8+dfsg-1ubuntu4.8
13 affected builds
Fixed in–
Ubuntu 22.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=jammyOther threatsAffected
  • 1:23.2.6+dfsg-1build1 – 1:24.2+dfsg-1
15 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1:22.0.7+dfsg-1build1 – 1:22.2+dfsg-1
15 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1:20.0.4+dfsg-1ubuntu1 – 1:20.2.2+dfsg-1ubuntu2+esm4
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OTP versions 27.3.4.19, 28.5.0.8, and 29.1.2 and corresponding ssl versions 11.2.12.14, 11.6.0.7, and 11.7.8. Users should upgrade to these fixed versions to remediate the vulnerability. No other mitigation steps are indicated in the advisory.

Description

An improper certificate validation vulnerability exists in the ssl application of Erlang/OTP, allowing a client with a certificate trusted by one SNI virtual host to authenticate to another SNI virtual host on the same listener by resuming its TLS 1.2 session. This occurs because the server maintains a single session cache per listener without binding cached sessions to the SNI name or client trust policy. This issue affects OTP versions from 18.0 up to but not including 27.3.4.19, 28.5.0.8, and 29.1.2, and corresponding ssl versions from 7.0 up to but not including 11.2.12.14, 11.6.0.7, and 11.7.8. TLS 1.3 is not affected.

References

Community reviews

Loading reviews…