Skip to main content
VulnerabilityPublished Updated

CVE-2025-2867: GitLab · Code Injection

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.2.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2.2, 17.9.3, 17.8.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.2.2, 17.9.3 or 17.8.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.8.0 <17.8.6
  • >=17.9.0 <17.9.3
  • >=17.10.0 <18.2.2
Fixed in
  • 17.8.6
  • 17.9.3
  • 18.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab versions to 17.8.6 or later for the 17.8.x branch, 17.9.3 or later for the 17.9.x branch, and 18.2.2 or later for the 17.10.x branch and beyond. Applying these updates will remediate the vulnerability.

Description

A code injection vulnerability (CVE-2025-2867) exists in GitLab Duo with Amazon Q affecting versions 17.8.0 through before 17.8.6, 17.9.0 through before 17.9.3, and 17.10.0 through before 18.2.2. This flaw allows a specially crafted issue to manipulate AI-assisted development features, potentially exposing sensitive project data to unauthorized users. The vulnerability has a medium severity rating and a patch is available.

References

Community reviews

Loading reviews…