Skip to main content
VulnerabilityPublished Updated

CVE-2024-1947: Improper Handling of Highly Compressed Data (Data Amplification) in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.0.1 : update gitlab when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.0.1, 16.11.3, 16.10.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.0.1, 16.11.3 or 16.10.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=13.2.4 <16.10.6
  • >=16.11.0 <16.11.3
  • >=17.0.0 <17.0.1
Fixed in
  • 16.10.6
  • 16.11.3
  • 17.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade affected GitLab versions to 16.10.6 or later for the 16.10.x branch, 16.11.3 or later for the 16.11.x branch, and 17.0.1 or later for the 17.0.x branch to remediate this issue.

Description

GitLab CE/EE versions from 13.2.4 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1 contain a vulnerability that allows denial of service (DoS) via crafted API calls exploiting improper handling of highly compressed data. This can cause service disruption.

References

Community reviews

Loading reviews…