CVE-2024-38479: Apache Traffic Server · Improper Input Validation Vulnerability
Source GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 9.2.6 : patch affected systems soon.
Data as of 30 Oct 2026, 00:42 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 9.2.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
AI-suggested
Users should upgrade Apache Traffic Server to version 9.2.6 or later, or to version 10.0.2 or later, where this vulnerability is fixed. No other mitigations are specified.
Description
CVE-2024-38479 is an Improper Input Validation vulnerability in Apache Traffic Server affecting versions from 8.0.0 through 8.1.11 and 9.0.0 through 9.2.5. The issue is resolved in versions 9.2.6 and 10.0.2. The vulnerability has a high severity with a CVSS score of 7.5 and can lead to integrity impact without requiring privileges or user interaction.