Skip to main content
CVE-2025-4748VulnerabilityPublished Updated

Erlang OTP (stdlib modules) · Path Traversal

Affects erlangSource GCVE Database

0
Authoritative record:CVE-2025-4748· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 1:18.3-dfsg-1ubuntu3.1+esm4 : update erlang when convenient.

Data as of 28 Oct 2026, 22:28 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1:18.3-dfsg-1ubuntu3.1+esm4, 1:20.2.2+dfsg-1ubuntu2+esm4, 1:22.2.7+dfsg-1ubuntu0.5+esm3 +3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:L/SC:N/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10erlangpkg:deb/ubuntu/erlang?arch=source&distro=questingOther threatsAffected
  • <1:27.3.4.1+dfsg-1
  • =1:27.3+dfsg-1ubuntu1
  • =1:27.3+dfsg-1ubuntu1.1
Fixed in
  • 1:27.3.4.1+dfsg-1
Ubuntu 24.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=nobleOther threatsAffected
  • <1:25.3.2.8+dfsg-1ubuntu4.4
Fixed in
  • 1:25.3.2.8+dfsg-1ubuntu4.4
Ubuntu 22.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=jammyOther threatsAffected
  • <1:24.2.1+dfsg-1ubuntu0.5
  • =1:24.2+dfsg-1
Fixed in
  • 1:24.2.1+dfsg-1ubuntu0.5
Ubuntu Pro 20.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1:22.2.7+dfsg-1ubuntu0.5+esm3
  • =1:22.2+dfsg-1
Fixed in
  • 1:22.2.7+dfsg-1ubuntu0.5+esm3
Ubuntu Pro 18.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1:20.2.2+dfsg-1ubuntu2+esm4
Fixed in
  • 1:20.2.2+dfsg-1ubuntu2+esm4
Ubuntu Pro 16.04 LTSerlangpkg:deb/ubuntu/erlang?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <1:18.3-dfsg-1ubuntu3.1+esm4
Fixed in
  • 1:18.3-dfsg-1ubuntu3.1+esm4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Erlang OTP (stdlib modules) allows Absolute Path Traversal, File Manipulation. This vulnerability is associated with program files lib/stdlib/src/zip.erl and program routines zip:unzip/1, zip:unzip/2, zip:extract/1, zip:extract/2 unless the memory option is passed. This issue affects OTP from OTP 17.0 before OTP 28.0.1, OTP 27.3.4.1 and OTP 26.2.5.13, corresponding to stdlib from 2.0 before 7.0.1, 6.2.2.1 and 5.2.3.4.

References

Community reviews

Loading reviews…