Skip to main content
CVE-2026-90872VulnerabilityPublished

dynamically evaluated code · Improper Neutralization of Directives

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-90872· Medium 6.6

Not known to be exploited · CVSS 6.6 Medium : upgrade to 2025.0.4 or 2024.0.7 when convenient.

Data as of 29 Oct 2026, 19:19 UTC

CVSS 3.1 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ProgressSoftware)CVSS 3.16.6
Patch
Available – fixed in 2025.0.4, 2024.0.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade WS_FTP Server to 2025.0.4 or 2024.0.7.

Affected software

ProductAffectedFixed in
Progress SoftwareWS_FTP ServerAffected
  • <2025.0.4
Fixed in
  • 2025.0.4
Progress SoftwareWS_FTP ServerAffected
  • <2024.0.7
Fixed in
  • 2024.0.7

AI-suggested

Upgrade WS_FTP Server to version 2024.0.7 or later, or 2025.0.4 or later, where this vulnerability is fixed. No other mitigation or workaround is provided. Since this is not a cloud service, patching the affected software versions is required to remediate the issue.

Description

A vulnerability in the Manager web console of Progress Software WS_FTP Server on Windows allows an authenticated Manager administrator to execute arbitrary commands with the privileges of the IIS worker process. This issue affects versions prior to 2024.0.7 and 2025.0.4. The flaw is due to improper neutralization of directives in dynamically evaluated code.

References

Community reviews

Loading reviews…