Skip to main content
CVE-2024-4835VulnerabilityPublished Updated

CVE-2024-4835: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.0.1 : patch gitlab soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.0.1, 16.11.3, 16.10.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 17.0.1, 16.11.3 or 16.10.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=15.11.0 <16.10.6
  • >=16.11.0 <16.11.3
  • >=17.0.0 <17.0.1
Fixed in
  • 16.10.6
  • 16.11.3
  • 17.0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab to version 16.10.6, 16.11.3, or 17.0.1 or later. Since patches are available, remediation should be performed promptly to mitigate the risk.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. This flaw allows attackers to inject malicious scripts into web pages, potentially enabling the exfiltration of sensitive user information. The vulnerability has been assigned CVE-2024-4835 and is rated with high severity. Official patches addressing this issue are available in versions 16.10.6, 16.11.3, and 17.0.1.

References

Community reviews

Loading reviews…