Skip to main content
VulnerabilityPublished Updated

CVE-2024-4207: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.2.2 : update gitlab when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.2.2, 17.1.4, 17.0.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.2.2, 17.1.4 or 17.0.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=5.1.0 <17.0.6
  • >=17.1.0 <17.1.4
  • >=17.2.0 <17.2.2
Fixed in
  • 17.0.6
  • 17.1.4
  • 17.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab to versions 17.0.6 or later, 17.1.4 or later, or 17.2.2 or later to remediate the issue. Applying these official fixes will prevent exploitation of this XSS vulnerability.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab where viewing an XML file in raw mode can cause it to render as HTML under certain conditions. This affects multiple version ranges of GitLab from 5.1 up to but not including 17.0.6, from 17.1 up to but not including 17.1.4, and from 17.2 up to but not including 17.2.2. The issue allows improper neutralization of input during web page generation. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…