CVE-2024-3092: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 16.10.2 or 16.9.4 soon.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.10.2, 16.9.4
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade gitlab to 16.10.2 or 16.9.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 16.9.4 or later and 16.10.2 or later to remediate this issue.
Description
A stored cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions starting from 16.9 before 16.9.4 and from 16.10 before 16.10.2. The flaw occurs in the diff viewer component and allows an attacker to inject malicious scripts that execute arbitrary actions on behalf of victims.