Skip to main content
VulnerabilityPublished Updated

CVE-2024-6530: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.4.2 : patch gitlab soon.

Data as of 26 Oct 2026, 17:16 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
2.1% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.4.2, 17.3.5, 17.2.9

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.4.2, 17.3.5 or 17.2.9.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.1.0 <17.2.9
  • >=17.3.0 <17.3.5
  • >=17.4.0 <17.4.2
Fixed in
  • 17.2.9
  • 17.3.5
  • 17.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab to versions 17.2.9, 17.3.5, or 17.4.2 or later to remediate this issue.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab that affects multiple version ranges. The flaw occurs when adding or authorizing an application, which under certain conditions can cause input to be rendered as HTML improperly. This vulnerability affects GitLab versions from 17.1 up to but not including 17.2.9, from 17.3 up to but not including 17.3.5, and from 17.4 up to but not including 17.4.2. A patch is available to address this issue.

References

Community reviews

Loading reviews…