Skip to main content
VulnerabilityPublished Updated

CVE-2024-7047: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 17.2.1 : patch gitlab soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.2.1, 17.1.3, 17.0.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.2.1, 17.1.3 or 17.0.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.6.0 <17.0.5
  • >=17.1.0 <17.1.3
  • >=17.2.0 <17.2.1
Fixed in
  • 17.0.5
  • 17.1.3
  • 17.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading GitLab to versions 17.0.5, 17.1.3, or 17.2.1 or later. Since a patch is available, remediation should be performed promptly to prevent exploitation. No additional vendor advisory indicates alternative mitigations or that no action is required.

Description

A cross-site scripting (XSS) vulnerability in GitLab CE/EE allows attackers to execute arbitrary scripts in the context of the logged-in user. This affects versions from 16.6 up to but not including 17.0.5, 17.1 up to but not including 17.1.3, and 17.2 up to but not including 17.2.1. The vulnerability permits improper neutralization of input during web page generation. A fix is available for the affected versions.

References

Community reviews

Loading reviews…