Skip to main content
VulnerabilityPublished Updated

CVE-2025-2255: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 17.10.1 soon.

Data as of 26 Oct 2026, 14:05 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.10.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.10.1.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=13.5.0 <17.10.1
Fixed in
  • 17.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading affected GitLab versions to 17.8.6, 17.9.3, or 17.10.1 or later. Users should follow official GitLab upgrade procedures to remediate this vulnerability.

Description

A Cross-Site Scripting (XSS) vulnerability exists in GitLab EE/CE affecting versions from 13.5.0 up to but not including 17.10.1. The issue arises from improper neutralization of input in certain error messages related to the AppSec component, potentially allowing injection of malicious scripts.

References

Community reviews

Loading reviews…