Skip to main content
VulnerabilityPublished Updated

CVE-2025-11224: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.5.2 : patch gitlab soon.

Data as of 26 Oct 2026, 17:16 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.5.2, 18.4.4, 18.3.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.5.2, 18.4.4 or 18.3.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=15.10.0 <18.3.6
  • >=18.4.0 <18.4.4
  • >=18.5.0 <18.5.2
Fixed in
  • 18.3.6
  • 18.4.4
  • 18.5.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade GitLab CE/EE to versions 18.3.6, 18.4.4, 18.5.2 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

GitLab CE/EE versions from 15.10 up to but not including 18.3.6, 18.4 up to but not including 18.4.4, and 18.5 up to but not including 18.5.2 contain a stored cross-site scripting (XSS) vulnerability in the Kubernetes proxy functionality. This vulnerability allows an authenticated user to execute malicious scripts due to improper input validation during web page generation. The issue has been remediated in versions 18.3.6, 18.4.4, and 18.5.2 and later.

References

Community reviews

Loading reviews…