Skip to main content
VulnerabilityPublished Updated

CVE-2025-6186: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 18.2.2 or 18.1.4 soon.

Data as of 26 Oct 2026, 14:05 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2.2, 18.1.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.2.2 or 18.1.4.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=18.1.0 <18.1.4
  • >=18.2.0 <18.2.2
Fixed in
  • 18.1.4
  • 18.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade to GitLab versions 18.1.4 or later and 18.2.2 or later to remediate the issue.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions 18.1.0 through before 18.1.4 and 18.2.0 through before 18.2.2. This flaw allows authenticated users to inject malicious HTML into work item names, potentially leading to account takeover.

References

Community reviews

Loading reviews…