CVE-2025-0314: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 17.8.1 : patch gitlab soon.
Data as of 26 Oct 2026, 13:47 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.8.1, 17.7.3, 17.6.4
Exploitation evidence
Disclosed: evidence found.
CVE published 28 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.8.1, 17.7.3 or 17.6.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available for this vulnerability. Users should upgrade affected GitLab CE/EE instances to versions 17.6.4, 17.7.3, 17.8.1 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE due to improper neutralization of input during web page generation. This affects specific versions from 17.2 up to but not including 17.6.4, 17.7 up to but not including 17.7.3, and 17.8 up to but not including 17.8.1. The vulnerability arises from improper rendering of certain file types, which can lead to XSS attacks. A patch is available for this issue.