Skip to main content
VulnerabilityPublished Updated

CVE-2025-7739: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 18.2.2 soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.2.2.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=18.2.0 <18.2.2
Fixed in
  • 18.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in GitLab version 18.2.2. Users should upgrade affected GitLab CE/EE instances to version 18.2.2 or later to remediate this vulnerability.

Description

A stored cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions 18.2.0 through before 18.2.2. Authenticated users could inject malicious HTML content into scoped label descriptions, which may be executed in other users' browsers under certain conditions. This issue has been fixed in version 18.2.2.

References

Community reviews

Loading reviews…