CVE-2025-4700: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.2.1 : patch gitlab soon.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.2.1, 18.1.3, 18.0.5
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.2.1, 18.1.3 or 18.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should upgrade to GitLab versions 18.0.5, 18.1.3, 18.2.1 or later to remediate this vulnerability. Applying these official fixes will mitigate the risk of exploitation.
Description
A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions from 15.10 up to but not including 18.0.5, from 18.1 up to but not including 18.1.3, and from 18.2 up to but not including 18.2.1. Under specific conditions, this flaw could allow an attacker to cause unintended content rendering in web pages. This issue has been addressed in the indicated fixed versions.