Skip to main content
VulnerabilityPublished Updated

CVE-2025-0475: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 17.9.1 soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.9.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 17.9.1.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=15.10.0 <17.9.1
Fixed in
  • 17.9.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 17.9.1 or later, or to the fixed versions 17.7.6 and 17.8.4 as applicable. Applying these official fixes will mitigate the vulnerability. No additional vendor advisory content is provided, so users should consult GitLab's official release notes for precise upgrade instructions.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE due to improper neutralization of input during web page generation. This issue affects versions from 15.10 up to but not including 17.9.1 and involves a proxy feature that may cause unintended content rendering under specific conditions. The vulnerability is rated as high severity. A patch is available to address this issue.

References

Community reviews

Loading reviews…