CVE-2025-14560: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.8.4 : patch gitlab soon.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.8.4, 18.7.4, 18.6.6
Exploitation evidence
Disclosed: evidence found.
CVE published 16 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.8.4, 18.7.4 or 18.6.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
GitLab has released official patches that remediate this vulnerability. Users should upgrade to versions 18.6.6 or later, 18.7.4 or later, or 18.8.4 or later to mitigate this issue. Applying these updates will prevent exploitation of the vulnerability.
Description
A cross-site scripting (XSS) vulnerability in GitLab CE/EE versions 17.1 through before 18.6.6, 18.7 through before 18.7.4, and 18.8 through before 18.8.4 could allow an authenticated user to inject malicious content into the vulnerability code flow, potentially enabling unauthorized actions on behalf of other users. GitLab has released patches to address this issue.