Skip to main content
VulnerabilityPublished Updated

CVE-2025-7734: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.2.2 : patch gitlab soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.2.2, 18.1.4, 18.0.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.2.2, 18.1.4 or 18.0.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=14.2.0 <18.0.6
  • >=18.1.0 <18.1.4
  • >=18.2.0 <18.2.2
Fixed in
  • 18.0.6
  • 18.1.4
  • 18.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade GitLab CE/EE to versions 18.0.6 or later, 18.1.4 or later, or 18.2.2 or later to remediate this issue. No additional mitigation steps are indicated.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions from 14.2 up to but not including 18.0.6, 18.1 up to but not including 18.1.4, and 18.2 up to but not including 18.2.2. This flaw could allow an attacker to inject malicious content and perform actions on behalf of users under certain conditions. The issue has been assigned CVE-2025-7734 and is rated with high severity. A patch is available to address this vulnerability.

References

Community reviews

Loading reviews…