Skip to main content
VulnerabilityPublished Updated

CVE-2025-2254: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 18.0.2 soon.

Data as of 26 Oct 2026, 17:16 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.0.2

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.0.2.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.9.0 <18.0.2
Fixed in
  • 18.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading affected GitLab instances to version 17.10.8, 17.11.4, 18.0.2 or later. Applying these official fixes will remediate the vulnerability.

Description

GitLab CE/EE versions from 17.9 up to but not including 18.0.2 contain a cross-site scripting (XSS) vulnerability in the snippet viewer functionality due to improper output encoding. This vulnerability allows attackers to inject malicious scripts during web page generation. A patch is available to address this issue.

References

Community reviews

Loading reviews…