CVE-2025-0811: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited : upgrade to 17.10.1 soon.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 17.10.1
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 17.10.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade affected GitLab CE/EE versions to 17.8.6, 17.9.3, or 17.10.1 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability exists in GitLab CE/EE due to improper neutralization of input during web page generation. This affects versions from 17.7 up to but not including 17.8.6, 17.9 up to but not including 17.9.3, and 17.10 up to but not including 17.10.1. The issue arises from improper rendering of certain file types, which can lead to XSS attacks. A patch is available to address this vulnerability.