Skip to main content
VulnerabilityPublished Updated

CVE-2026-1090: GitLab · Cross-site Scripting

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.9.2 : patch gitlab soon.

Data as of 26 Oct 2026, 10:12 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.9.2, 18.8.6, 18.7.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.9.2, 18.8.6 or 18.7.6.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=10.6.0 <18.7.6
  • >=18.8.0 <18.8.6
  • >=18.9.0 <18.9.2
Fixed in
  • 18.7.6
  • 18.8.6
  • 18.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in GitLab versions 18.7.6, 18.8.6, and 18.9.2. Users should upgrade affected GitLab instances to these versions or later to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official fix.

Description

GitLab versions from 10.6 up to but not including 18.7.6, 18.8 up to 18.8.6, and 18.9 up to 18.9.2 contain a cross-site scripting (XSS) vulnerability. This issue occurs when the markdown_placeholders feature flag is enabled, allowing an authenticated user to inject JavaScript due to improper sanitization of placeholder content during markdown processing. The vulnerability has been remediated in versions 18.7.6, 18.8.6, and 18.9.2.

References

Community reviews

Loading reviews…