CVE-2026-6073: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.11.3 : patch gitlab soon.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.11.3, 18.10.6, 18.9.7
Exploitation evidence
Disclosed: evidence found.
CVE published 18 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.11.3, 18.10.6 or 18.9.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released by GitLab. Users should upgrade affected GitLab EE instances to versions 18.9.7, 18.10.6, or 18.11.3 or later to remediate this vulnerability.
Description
A cross-site scripting (XSS) vulnerability in GitLab EE versions from 18.7 up to but not including 18.9.7, 18.10 up to but not including 18.10.6, and 18.11 up to but not including 18.11.3 allows an authenticated user to execute arbitrary JavaScript in other users' browsers due to improper input sanitization. This issue has been remediated in the specified fixed versions.