Skip to main content
CVE-2026-7481VulnerabilityPublished Updated

CVE-2026-7481: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.11.3 : patch gitlab soon.

Data as of 26 Oct 2026, 07:57 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.11.3, 18.10.6, 18.9.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 18.11.3, 18.10.6 or 18.9.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=16.4.0 <18.9.7
  • >=18.10.0 <18.10.6
  • >=18.11.0 <18.11.3
Fixed in
  • 18.9.7
  • 18.10.6
  • 18.11.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading GitLab EE to versions 18.9.7, 18.10.6, or 18.11.3 or later. Applying these official fixes will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A cross-site scripting (XSS) vulnerability exists in GitLab EE versions from 16.4 up to but not including 18.9.7, 18.10 up to 18.10.6, and 18.11 up to 18.11.3. This flaw allows an authenticated user with developer-role permissions to execute arbitrary JavaScript in other users' browsers due to improper input sanitization. The issue has been remediated in the specified fixed versions.

References

Community reviews

Loading reviews…