CVE-2026-5262: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.11.1 : patch gitlab soon.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.11.1, 18.10.4, 18.9.6
Exploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.11.1, 18.10.4 or 18.9.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading GitLab CE/EE to versions 18.9.6, 18.10.4, or 18.11.1 or later. Applying these official fixes will remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability in GitLab CE/EE versions from 16.1.0 before 18.9.6, 18.10.0 before 18.10.4, and 18.11.0 before 18.11.1 could allow an unauthenticated user to access tokens in the Storybook development environment due to improper input validation. This issue has been remediated in the specified fixed versions.