CVE-2026-0752: GitLab · Cross-site Scripting
Affects gitlabSource GCVE Database
Not known to be exploited · fixed in 18.9.1 : patch gitlab soon.
Data as of 26 Oct 2026, 10:12 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.9.1, 18.8.5, 18.7.5
Exploitation evidence
Disclosed: evidence found.
CVE published 2 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade gitlab to 18.9.1, 18.8.5 or 18.7.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamigitlabpkg:bitnami/gitlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading affected GitLab CE/EE instances to versions 18.7.5, 18.8.5, or 18.9.1 or later. No additional mitigation steps are indicated by the vendor advisory.
Description
A cross-site scripting (XSS) vulnerability was identified in GitLab CE/EE affecting versions from 16.2 up to but not including 18.7.5, 18.8 up to but not including 18.8.5, and 18.9 up to but not including 18.9.1. This vulnerability could allow an unauthenticated user to inject arbitrary scripts into the Mermaid sandbox UI under certain conditions. GitLab has released patches to remediate this issue.