Skip to main content
CVE-2026-118552VulnerabilityPublished

Drupal AI · Cross-site Scripting

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-118552· High

Not known to be exploited : upgrade to 1.5.2 or 1.4.11 soon.

Data as of 30 Oct 2026, 07:17 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Thin evidence

One scorer or none
Patch
Available – fixed in 1.5.2, 1.4.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade AI (Artificial Intelligence) to 1.5.2 or 1.4.11.

Affected software

ProductAffectedFixed in
DrupalAI (Artificial Intelligence)Affected
  • >=1.5.0 <1.5.2
Fixed in
  • 1.5.2
DrupalAI (Artificial Intelligence)Affected
  • <1.4.11
Fixed in
  • 1.4.11

AI-suggested

If you cannot patch yet, consider implementing input validation and output encoding as defensive measures to mitigate XSS risks.

Description

A Cross-Site Scripting (XSS) vulnerability exists in the Drupal AI (Artificial Intelligence) component due to improper neutralization of input during web page generation. This vulnerability affects versions from 0.0.0 to 1.4.11 and from 1.5.0 to 1.5.2 of the Drupal AI module. The flaw allows injection of malicious scripts into web pages, potentially impacting users who view the affected content.

References

Community reviews

Loading reviews…