Skip to main content
VulnerabilityPublished

CVE-2026-6793: q-smart-next-poll · Improper neutralization of input during web page generation ('cross-site scripting') vulnerability in

Affects q-smart-next-pollSource GCVE Database

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.8.7 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade q-smart-next-poll to 1.8.7.

Affected software

ProductAffectedFixed in
npmq-smart-next-pollpkg:npm/q-smart-next-pollOther threatsAffected
  • <1.8.7
Fixed in
  • 1.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should apply standard XSS mitigations such as input validation and output encoding where possible.

Description

A stored cross-site scripting (XSS) vulnerability exists in Bifra Engineering Consulting Ltd.'s Q-smart NexT Poll before version 1.8.7. The vulnerability arises from improper neutralization of input during web page generation, allowing malicious scripts to be stored and executed in users' browsers. This vulnerability has a moderate severity rating and requires user interaction with low privileges to exploit.

References

Community reviews

Loading reviews…